Connection issues for VETTrak Desktop

Incident Report for VETtrak

Resolved

This incident has been resolved.
Posted Feb 09, 2026 - 19:43 AEDT

Monitoring

We have implemented fixes to address the connectivity issues and will continue to monitor the environment and make adjustments as required.
Posted Feb 09, 2026 - 16:36 AEDT

Identified

The issues have been identified and we are currently remediating. We apologise for any inconvenience this may have caused

You may notice a delay the first time you reconnect back into the environment while it loads your user session.
Posted Feb 09, 2026 - 14:31 AEDT

Investigating

We are aware that some customers are experiencing issues reconnecting to the VETtrak environment following an unexpected disconnection. Our team is currently investigating the cause and will provide a further update as soon as more information becomes available.
Posted Feb 09, 2026 - 13:25 AEDT
This incident affected: VETtrak (VETtrak Desktop Software).