Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 09, 2026 - 21:00 AEDT
Scheduled
VETtrak Desktop will be under going maintenance to finish remediation work. We expect the outage to last approximately 30 minutes with other services unaffected.
Posted Feb 09, 2026 - 19:46 AEDT
This scheduled maintenance affected: VETtrak (VETtrak Desktop Software).