VETtrak Licence Issues - 04/06/2024
Incident Report for VETtrak
Resolved
This incident has been resolved.
Posted Jun 04, 2024 - 10:51 AEST
Investigating
We are currently investigating an issue with the licence management for VETtrak, which is impacting some customers ability to log in.
This is being investigated by the team and more updates will be provided shortly.
Posted Jun 04, 2024 - 10:16 AEST
This incident affected: VETtrak (VETtrak Desktop Software).