USI Outage - 07/07/2025

Incident Report for VETtrak

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 16:03 AEST

Investigating

We are currently aware of an incident impacting access to the USI system. This is being investigated and more information will be provided shortly.
Posted Jul 07, 2025 - 10:38 AEST
This incident affected: Unique Student Identifier (USI) (3rd Party).