Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 28, 2025 - 21:30 AEST
Scheduled
We will be undergoing routine maintenance on the database platform this evening. We do not expect issues to arise.
Posted Jul 28, 2025 - 21:18 AEST
This scheduled maintenance affected: VETtrak (VETtrak Desktop Software, Portals (Trainer, Student, VTDocs and Progress), API (web connector)) and VETEmbark.